Dancer2 0.203001 improves speed of apps, fixes missing dependency

Dancer2 0.203001 is on its way to a CPAN mirror near you. It is essentially a maintenance release, with only two minor changes:

  • Class::Load was replaced by Module::Runtime. This will result in a slightly faster execution time for your Dancer2 apps. This had been applied previously, but was erroneously undone by another commit. Thanks to veryrusty for noticing and fixing!

  • The minimum version of List::Util needed by Dancer2 was omitted from 0.203000, causing some headaches for users of older versions of List::Util.

The full changelog follows:

0.203001  2016-09-03 20:59:47-05:00 America/Chicago

[ BUG FIXES ]
* GH #1237: Specify minimum version of List::Util required for pair*
  functionals. (Russell @veryrusty Jenkins)

[ ENHANCEMENTS ]
* PR #1242: Replace Class::Load with Module::Runtime (Russell 
  Jenkins - @veryrusty)

You can always find us at irc.perl.org#dancer if you have any questions.

The Perl Dancer 2016 conference is just a few short weeks away! It’s not too late to attend. Check out the conference website for more information.

Happy Dancing!

Leave a comment

About Jason A. Crome

user-pic Dancer developer, entrepreneur, pilot, and hockey player.