September 2011 Archives

Task:: is broken

A friend asked my why I'm still using Bundle:: instead of the superior Task:: It was Bundle::CPANReporter2

If I install a Task for 5.15.3 plain and then install it for the debugging version, it does nothing and says "already installed". Different archlibs are not checked.

I had to do the following to install all the Task::Kensho XS modules:

$ perl -lne'/=item L<(.+?)[\|>]/ and print $1' <path-to-Task/Kensho.pm>
  | xargs perl5.15.3d-nt -S cpan

Bundle::CPANReporter2 was only created to pull in required XS modules. Plain perl modules are found in @INC anyway in the previous perls.