Google misleads users

RT #96394 in a nuthsell:
user searched for Perl CPAN PayPal, Google led to
Business-PayPal-0.03 on search.cpan.org which pointed the user
to "Latest Release: Business-PayPal-0.04" which he missed and thus opened the ticket.

In fact, as of this writing, the latest release is is 0.13, but who cares if you make sure only the stable, version-independent link is indexable by Google.

1 Comment

Two things:

1. Google doesn't care what the latest is. It cares about what is being linked to.

2. SCO knows that 0.13 is the latest: [ http://search.cpan.org/~phred/Business-PayPal/ ] Why it doesn't show that on the module page is the question, and smells like a bug. Have you reported it yet at cpansearch@perl.org ?

Leave a comment

About Gabor Szabo

user-pic Perl author and trainer. Usually writing on other sites: Writing the Perl Maven tutorial Perl 6 articles. Started a Perl IDE. Running the Weekly Perl newsletter. My personal blog.