Released Ouch 0.0404

Pushed Ouch 0.0404 to CPAN. It turns out I was using some Perl 5.10 and 5.12 features (use parent and use overload respectively) and that was causing some CPAN testers errors, and also problems for folks on old Perls.  So I’ve made Ouch explicitly require Perl 5.12 going forward. 

[From my blog.]


You shouldn't need to bump the dep up to 5.12 for either of these -- just add 'parent' to your prereq list (it's dual-lifed!) And overload is available on older perls - e.g.

You can use Perl::MinimumVersion (the handy 'perlver --blame command) to see what in your code requires certain versions.

Module::CoreList is the other tool you need.
corelist -a overload would have told you that overload has been around since perl 5.002.

Leave a comment

About JT Smith

user-pic My little part in the greater Perl world.